System Requirements and Browser Compatibility

Follow


To access Mindflash in a browser, the minimum system requirements are below:

Operating System: 
Mac 10.5 or higher 
Windows 7 or higher

Internet Connection: 
Cable/DSL or faster 

Browser: 
Firefox 25+ (Download)
Chrome latest version (Download)
Internet Explorer 10+ (Download)
Safari 7+ (Download)


Tablets:

Mindflash supports use of tablets and mobile devices by Trainees using the web browser on the device.  Trainees can access their account and take courses.  Additionally, iPad users can download the Mindflash iPad app and access their courses that way.

 

Mobile Devices:

Trainees can take courses on mobile devices operating on Andriod 4.2+ or iOS 8+.  Trainees access their courses in the device's browser.

A 3G connection or better is recommended for taking courses.

 

 


 

 

Have more questions? Submit a request

Comments

Powered by Zendesk